Altere a versão do PHP usada pelo Composer no Windows

Já usei o WAMP 2.5 com o PHP 5.5.12 e com o Composer. O php está ligado:

C:\wamp\bin\php\php5.5.12 

Para o novo projeto, eu preciso usar o nginx e instalar o PHP 7. O php está ativado:

 C:\nginx\php 

Agora, usando o GitBash MINGW32, tentei instalar o laravel 5.3 usando o Composer create-project mas disse

 [InvalidArgumentException] Could not find package laravel/laravel with version 5.3 in a version installable using your PHP version 5.5.12. 

Eu já coloquei C:\wamp\bin\php\php5.5.12 e C:\nginx\php na variável Windows System PATH.

Como faço para mudar a versão do PHP usada pelo Composer?

Três maneiras de fazer isso, de verdade.

Crie um alias no .bashrc para executar sempre o compositor com a versão correspondente

Algo como alias ncomposer=`/path/to/php /path/to/composer.phar `

Especifique o caminho para a versão do PHP dentro do próprio composer.phar

Isso é especificado no início do arquivo: #!/path/to/php php . Então o compositor deve correr com composer.phar

NB! A linha desaparecerá após a auto-atualização, portanto, não é uma solução confiável.

Mova o caminho com a versão mais recente do PHP

Se você colocar C:\nginx\php primeiro, ele deve ser usado por padrão ao usar o compositor.

Espero que isto ajude!