Conclusão: não instale o laravel / framework v4.2.22

Estou tentando girar meu antigo site L4 no Ocean Digital. Depois de clonar tudo, tentei correr:

atualização do compositor sudo

Do not run Composer as root/super user! See https://getcomposer.org/root for details Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. Problem 1 - Conclusion: don't install laravel/framework v4.2.22 - Conclusion: don't install laravel/framework v4.2.21 - Conclusion: don't install laravel/framework v4.2.20 - Conclusion: don't install laravel/framework v4.2.19 - Conclusion: don't install laravel/framework v4.2.18 - Conclusion: don't install laravel/framework v4.2.17 - Conclusion: don't install laravel/framework v4.2.16 - Conclusion: don't install laravel/framework v4.2.15 - Conclusion: don't install laravel/framework v4.2.14 - Conclusion: don't install laravel/framework v4.2.13 - Conclusion: don't install laravel/framework v4.2.12 - Conclusion: don't install laravel/framework v4.2.11 - Conclusion: don't install laravel/framework v4.2.10 - Conclusion: don't install laravel/framework v4.2.9 - Conclusion: don't install laravel/framework v4.2.8 - Conclusion: don't install laravel/framework v4.2.7 - Conclusion: don't install laravel/framework v4.2.6 - Conclusion: don't install laravel/framework v4.2.5 - Conclusion: don't install laravel/framework v4.2.4 - Conclusion: don't install laravel/framework v4.2.3 - Installation request for zizaco/entrust dev-master -> satisfiable by zizaco/entrust[dev-master]. - Conclusion: don't install laravel/framework v4.2.2 - Conclusion: don't install laravel/framework v4.2.1 - zizaco/entrust dev-master requires illuminate/cache ~5.0 -> satisfiable by illuminate/cache[v5.0.0, v5.0.22, v5.0.25, v5.0.26, v5.0.28, v5.0.33, v5.0.4, v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.41, v5.1.6, v5.1.8, v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.45, v5.2.6, v5.2.7, v5.3.0, v5.3.16, v5.3.23, v5.3.4, v5.4.0, v5.4.13, v5.4.9]. - don't install illuminate/cache v5.0.0|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.0.22|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.0.25|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.0.26|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.0.28|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.0.33|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.0.4|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.1|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.13|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.16|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.2|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.20|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.22|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.25|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.28|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.30|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.31|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.41|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.6|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.1.8|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.0|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.19|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.21|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.24|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.25|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.26|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.27|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.28|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.31|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.32|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.37|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.43|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.45|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.6|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.2.7|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.3.0|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.3.16|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.3.23|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.3.4|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.4.0|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.4.13|don't install laravel/framework v4.2.0 - don't install illuminate/cache v5.4.9|don't install laravel/framework v4.2.0 - Installation request for laravel/framework 4.2.* -> satisfiable by laravel/framework[v4.2.0, v4.2.1, v4.2.10, v4.2.11, v4.2.12, v4.2.13, v4.2.14, v4.2.15, v4.2.16, v4.2.17, v4.2.18, v4.2.19, v4.2.2, v4.2.20, v4.2.21, v4.2.22, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9]. 

Como eu paro isto ?

O ramo mestre do pacote zizaco/entrust requer Laravel 5. A última versão etiquetada do pacote zizaco/entrust que suporta o Laravel 4 é 1.3.0 . Você precisa atualizar seu arquivo composer.json para exigir "zizaco/entrust": "1.3.*" , Em vez de dev-master.