FOSUserBundle e Symfony 3.0?

FOSUserBundle funciona com symfony 3? Não consigo ver nenhuma informação sobre isso em seu site.

Acabei de instalar uma nova cópia do Symfony 3, fiz a composer update e tentei instalar o FOSUserBundle.

Recebendo algo não muito amigável no console;)

 composer require friendsofsymfony/user-bundle Problem 1 - Conclusion: remove symfony/symfony v3.0.0 - Conclusion: don't install symfony/symfony v3.0.0 - friendsofsymfony/user-bundle v1.3.0 requires symfony/security-bundle 2.1.* -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9]. - friendsofsymfony/user-bundle v1.3.1 requires symfony/security-bundle >=2.1, satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9]. - friendsofsymfony/user-bundle v1.3.2 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.8.0]. - friendsofsymfony/user-bundle v1.3.3 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.8.0]. - friendsofsymfony/user-bundle v1.3.4 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.8.0]. - friendsofsymfony/user-bundle v1.3.5 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.8.0]. - friendsofsymfony/user-bundle v1.3.6 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.8.0]. - don't install symfony/security-bundle v2.1.0|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.1|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.10|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.11|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.12|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.13|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.2|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.3|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.4|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.5|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.6|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.7|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.8|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.1.9|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.0|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.1|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.10|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.11|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.2|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.3|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.4|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.5|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.6|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.7|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.8|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.2.9|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.0|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.1|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.10|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.11|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.12|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.13|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.14|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.15|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.16|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.17|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.18|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.19|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.2|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.20|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.21|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.22|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.23|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.24|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.25|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.26|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.27|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.28|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.29|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.3|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.30|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.31|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.32|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.33|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.34|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.35|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.4|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.5|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.6|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.7|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.8|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.3.9|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.0|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.1|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.10|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.2|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.3|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.4|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.5|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.6|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.7|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.8|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.4.9|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.0|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.1|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.10|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.11|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.12|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.2|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.3|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.4|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.5|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.6|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.7|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.8|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.5.9|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.0|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.1|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.10|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.11|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.12|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.2|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.3|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.4|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.5|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.6|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.7|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.8|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.6.9|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.0|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.1|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.2|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.3|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.4|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.5|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.6|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.7.7|don't install symfony/symfony v3.0.0 - don't install symfony/security-bundle v2.8.0|don't install symfony/symfony v3.0.0 - Installation request for symfony/symfony 3.0.* -> satisfiable by symfony/symfony[v3.0.0]. - Installation request for friendsofsymfony/user-bundle ^1.3 -> satisfiable by friendsofsymfony/user-bundle[v1.3.0, v1.3.1, v1.3.2, v1.3.3, v1.3.4, v1.3.5, v1.3.6]. 

No momento, não há uma versão etiquetada (versão oficial) para suporte da nova versão do framework, BTW, neste problema github diz que:

no ramo mestre agora é compatível com o Symfony.

Então tente com esta configuração do compositor

 friendsofsymfony/user-bundle: "dev-master" 

Espero que esta ajuda

Este comando funcionou para mim com o Symfony 3.2.1:

 composer require friendsofsymfony/user-bundle "~2.0@dev" 

Editando meu compositor.json para include

 "friendsofsymfony/user-bundle": "^2.0.0" 

e depois correndo

 composer update 

trabalhou para mim depois de encontrar esta página de embalagens

O resultado final (de instalar o pacote) é o mesmo e, na minha opinião, a declaração do requisito parece / se sente melhor no meu projeto ao não ser um ramo do dev.