Laravel: seus requisitos não podem ser resolvidos para um conjunto de pacotes instalável

Estou tentando instalar o Laravel no sistema local e estou recebendo erro.

SO: ubuntu 12.04 LTS

Servidor web: Nginx

PHP: PHP 5.3.10

passo 1 :

$ git clone https://github.com/laravel/laravel.git my_project 

passo 2 :

 my_project$ composer install 

Estou recebendo o seguinte erro.

 Loading composer repositories with package information Installing dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. Problem 1 - laravel/framework v4.2.1 requires php >=5.4.0 -> no matching package found. - laravel/framework v4.2.0 requires php >=5.4.0 -> no matching package found. - Installation request for laravel/framework 4.2.* -> satisfiable by laravel/framework[v4.2.0, v4.2.1]. Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see  for more details. Read  for further common problems. 

Abra o arquivo do compositor.json e altere a versão da estrutura para o seguinte:

 "laravel/framework": "4.0.*" 

ao invés de

 "laravel/framework": "4.2.*" 

Você também pode resolver isso atualizando seu php para a versão 5.4. * Ou 5.5. * 🙂

Dica para aqueles que começam com Laravel. Resolvi o problema acima, atualizando meu PHP. Laravel requer PHP> = 5.4 http://laravel.com/docs/4.2/installation#server-requirements