Não é possível entrar no site usando as api’s do Facebook

Eu tenho algum código php que funcionou bem no meu antigo servidor. Mudei o código php para um novo servidor, e agora não consigo usar os api do Facebook para fazer login no meu site usando um login no Facebook.

Aqui está uma captura de canvas do que acontece no novo servidor:

insira a descrição da imagem aqui Maior versão aqui .

Verifiquei o arquivo error.log do apache e não vejo mensagens de erro.

Por que isso aconteceria em um novo servidor?

Há muitas razões para isto

  • Verifique se os domínios se combinam no código e nas configurações
  • Verifique se as URLs coincidem no código e nas configurações
  • verifique se as URLs de login para autenticação correspondem
  • Verifique se o segredo do aplicativo não mudou
  • Verifique se o modo sandbox está desligado
  • Verifique o access do aplicativo a partir de uma conta de desenvolvedor e não uma conta de teste
  • Verifique se o URL ao qual você está levando, tem todos os dados necessários.

Se é um ambiente móvel (isto é, do teste para a vida), serão os URLs do seu site. Acesse a página de configurações do seu aplicativo em http://developers.facebook.com/apps/ e atualize o URL do seu site lá.

Não deve ter nada a ver com o Apache, por favor, adicione algumas partes do seu código. Você também tem certeza sobre a URL da canvas e a configuração da ID do aplicativo com seu novo servidor?

vá para aplicativos >> seu app >> editar aplicativo Veja se o URL fornecido está correto

verifique se o appId e appSecret estão corretos

Verifique o URL do seu site na configuração do aplicativo enquanto ele contém o protocolo do servidor adequado, como http: // ou https: //